Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 19, 2025 - 15:30 CDT
Scheduled
We will be swapping out equipment in the core of our network. There will likely be some down time during this process.
Posted May 19, 2025 - 14:31 CDT
This scheduled maintenance affected: Main Network Status and Campus Status (Primary School Status, Elementary School Status, Middle School Status, High School Campus).